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Module 2.3 – Creating Web Pages 
 
Introduction 
 
To most people, the Internet has come to mean the World Wide Web. Although there are 
other applications you can use when connected to the Internet, the mast majority of users 
mainly spend their time searching for and viewing web pages.  
 
In the early days of the World Wide Web, all pages were created using HTML codes in a text 
editor. This was a time consuming process and the results were often unsatisfactory.  
 
Nowadays the majority of web pages are coded using a web page creation program that 
closely resembles a word processing program but which produces HTML documents. 
 
These programs are often called WYSIWYG editors. This stands for What You See Is What 
You Get and is so called because you see what the web page will look like when viewed in a 
web browser. 
 
It is still important to have knowledge of HTML for fine tuning and additional programming of 
web pages. 
 
In this module we will use Macromedia Dreamweaver, an industry standard web editor. 
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What You Will Learn 
 
In this module you will learn how to create a website by creating and linking individual web 
pages. These pages will include text, formatted in different ways, images, tables, lists and 
links.  
 
How You Will Learn This 
 
You will create a website. Your first website will help you learn the basics of creating a 
website in Dreamweaver by creating a website with descriptions of how to do magic tricks.  
 
Why You Will Learn This 
 
As the World Wide Web becomes an essential tool for storing information it is important that 
you are able to present data in HTML format and understand the process of making this 
information available to a world wide audience. 
 
The Magic Website 
 
You may copy the instructions for each illusion by clicking here. 
 
You may copy images by clicking here and saving to your own folder or by searching for 
pictures on the Internet. 
 
Your website must include instructions for at least 5 card tricks and at least 5 other types of 
trick. Choose from the following list. 
 

Card Tricks Non Card Tricks 
Impromptu Card Find 
Card on the ceiling 
Card Warp 
Elevator Card 
Bottoms Up 
Magic in a Glass 1 
Magic in a Glass 2 
The Three Amigos 
Mathomatics 
Ace Shake 
Two Card Monte 
Cough 
Card in Bottle 
Card Through Window 
Kundalini Rising 

Levitation 
Group Human Levitation 
Floating Bill and Small Objects Levitation 
Can Floating on Air 
Coin Island 
Magnetic Matches 
The Glass Balance 
Crazy Mans Handcuffs 
Broken and Restored Toothpick 
Eye Popper 
Penetrating Ashes 
Psychic Dice 
The Jumping Rubber Band 
Fly Resurrection 
Tax Disc Removal 
String Magic 
Vanishing Coin 
Coin Bite 
Coin Optical Illusion 
Minus Your Money 
Easy Coin Vanish 
Palm Penetration 
Twisting Arm Illusion 
Psycho Kinetic Time 
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Task 1 - The Dreamweaver Interface 
 
Dreamweaver allows users to work with their web pages in several ways. 
 

 
Design view  Shows page layout  

 
Design and Code view Shows layout alongside HTML codes  

 
Code view Shows the HTML codes only  

 
Most often you will use Design View but sometimes, when fine tuning pages or adding 
additional features, you could use either of the two coding views.  
 
When you launch Dreamweaver you are presented with a blank, untitled web page. There are 
some important rules to follow when creating web pages. 
 
Do not include spaces in file names, e.g. call a file 'taskone.htm' or 'task_one.htm' rather 
than 'task one.htm'.  
 
Your first page should always be called 'index.htm' as this is the default page a browser 
would search for. 
 
For a small site it is easiest to store all files in one folder. Larger sites benefit from an 
organised folder structure e.g. the Clavius web site is divided into S1, S2, S3 etc. folders and 
further sub-divided into mod1, mod2, mod3 etc. folders. It is also common practice to keep 
HTML documents and image files in separate folders.  
 

• By launching Macromedia Dreamweaver and calling up a Save As dialog box, create a 
folder in your network drive called Magic.  

 
• In this Magic folder, create two subfolders called HTML and Images.  

 
• In the Magic folder, save a Dreamweaver document called Index. 

 
• In the HTML folder, create a document called Menu. 
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Task 2 – Formatting Text  
 
In many ways, Dreamweaver works like a word processor. It allows you to enter text and 
then format this text in various ways.  
 
Text can be formatted using either the Properties toolbox or by choosing different options 
from the Text menu.  
 

 
 

 

Some differences between Dreamweaver  and a word 
processor include:  
 

• Font sizes are not specified as a set number. 
Instead, you can choose size 1 to 7, small to 
large or +7 to -7, bigger or larger than normal.  

 
• If you create a web page using a particular font, 

anyone viewing the web page must have the 
same font installed. Dreamweaver uses families 
of similar, commonly used fonts. 

 
• Font colours must be chosen from a palette of 

‘web safe’ colours that can be accurately 
displayed in all web browsers. 

 
• Open your Index file in Dreamweaver. 

 
• Enter the following text: 

 
Amazing Magic Tricks You Can Learn Quickly 
Click Here To Begin 

 
• Format this text by changing the following:  

 
Font Size 
Font Colour 
Style 
Alignment 
Font 
And any other property. 

 
• Preview this document in Internet Explorer by selecting File -> Preview in Browser or 

by pressing F12. Do this frequently when creating a website to test your pages. 
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Task 3 – HTML Codes 
 
When using Dreamweaver you generally do not need to worry about the underlying HTML 
codes of the web pages you produce but it is sometimes necessary to edit HTML directly. 
 
HTML codes are usually of the form: 
 
 <opening tag>  </closing tag> 
 
For example, the HTML code to make text bold would be: 
 
 <B>  </B> or <strong>  </strong> 
 
And any text between these tags would be made bold. 
 

• Switch to Code and Design view, , in Dreamweaver 
 

• Type your name and highlight this text  
 

• By formatting this text using the tools below, copy and complete the following table: 
 

Tool  HTML Code 

 <em>  </em> 
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Task 4 – Creating a Menu 
 
In Dreamweaver you can format lists in two ways – ordered and unordered. 
 
Ordered lists are lists where numbers are automatically inserted for each item on the list. 
Unordered lists are lists where bullet points are automatically inserted for each item on the 
list. 
 
You will create a list of tricks that you can learn from your website.  
 

• Open the file in the HTML folder called Menu  
 

• Enter the following text: 
 

Card Tricks 
Trick 1 
Trick 2 
Trick 3 
Trick 4 
Trick 5 
 
Other Tricks 
Trick 1 
Trick 2 
Trick 3 
Trick 4 
Trick 5 
 
Contact Me 

 

• Highlight the five card tricks and press the Unordered list tool,  
 

• Highlight the five other tricks and press the Ordered List Tool,  
 

• Format this text  
 

• Preview and save this file 
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Task 5 – Inserting Graphics  
 
The World Wide Web has been responsible for the huge growth of the Internet. This is 
because the Web allows you to present information in an engaging way. One of the most 
important elements in web pages is graphics.  
 
Different types of graphic can be inserted in web pages, the most commonly used graphic 
types are JPEGs, GIFs and PNGs.  
 
Insert an image in one of three ways: 
 

Click the Insert Image Tool  and choose which image file you require 
 
Choose Image from the Insert menu and choose which image file you require 
 
Press Ctrl + Alt + I on your keyboard and choose which image file you require 

 
 
Do the following: 
 

• From the Central Resource Library copy any of the magic images you want to use on 
your web site. 

 
• On index.htm add an appropriate image. 

 
• On menu.htm add an appropriate image 

 
• Preview each document in Internet Explorer 

 
Answer the following questions in your jotter. 
 
1. Using Webopaedia, find the meaning of the following graphic types. 
 
 (a) JPEG 
 (b) GIF 

(c) PNG 
(d) TIFF 
(e) BMP 

 
2. Why are some graphic types more suitable for use on web pages than others?
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Task 6 - Changing Page and Link Properties  
 
There are several properties that you can change by choosing the Modify menu and selecting 
Page Properties.  
 

 
 
Important information to modify using this dialog box include:  
 

The document title - this is the name that appears in the title bar and task bar when 
viewing the web page in Internet Explorer 
Your page background - this can be a colour or it can be an image. If it is a small 
image it will be tiled.  
Text colour – changing text colour here sets the colour for the whole document. You 
can still use the Properties toolbox to change the colour of individual words or 
sentences.  
Link colours – links are hotspots that you can click on to move to another page. 
Having a different colour makes the link stand out from normal text. Active link is the 
colour that flashes on as a link is clicked on and Visited Link is the colour that a link 
changes to show you have visited the link previously. 

 
 

• Open Index and Menu 
 
• Give appropriate titles to each, set backgrounds, text and link colours for each page 

 
• Preview each document 
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Task 7 - Tables  
 
Tables can, of course, be used to store information in a structured, organized way. But they 
are also valuable tools for organizing page layouts.  
 
To insert a table choose Insert -> Table or press Ctrl+Alt+T. 
 

 
 
Choose the number of rows and columns. Width is the proportion of the page that the table 
occupies. Border is the thickness of the line surrounding each table cell, set this to zero for no 
border. Cell Padding is is the number of pixels between a cell’s content and the cell 
boundaries. Cell Spacing is the number of pixels between adjacent table cells.  
 

• Launch Macromedia Dreamweaver 
 
• In a new document create the following table 

 
Magic Trick Name 

Effect  
Preparation  
Method  

 
• Use the Merge Cells command in the top row of the table to convert two cells to one, 

large cell. 
 
• Copy and paste the information for one of the tricks to this table 

 
• Save this document as Trick1 (or a name that describes the trick) 

 
•  Repeat for the other tricks in your site 

 
• Format the text as you wish, inserting images where appropriate 

 
• Preview and save each document 
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Task 8 - Creating Links 
 
Links on web pages are some of the most important components of web pages. Links can be 
one of three types; internal, external and email links. Links can be text or images.  
 
Internal links are links to other pages in your own website. External links are links to other 
people’s websites; these links are of the form, http://www.staloysius.org/news. Email links 
are links that, when you click on them, launch and allow you to send an email to someone.  
 

• Open the Index file 
 

• Highlight the text ‘Click here to enter’ 
 

• In the Properties toolbox, click on the folder icon and link to menu.htm 
 

 
 
• Save this document 
 
• Open the Menu file 

 
• For Trick 1, highlight the text in menu file and link to the Trick1 file created in Task 6 

 
• Repeat this for all tricks on your list 
 
• Highlight the text ‘Contact Me’ 
 
• Choose Insert -> Email Link 
 
• Enter your own email address 
 

 
 

• Preview this file, testing each link on the page 
 
• Save this file 
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Dreamweaver Extension Tasks 
  
Frames  
 
Surfing the web you will encounter frames on numerous occasions. Generally frames are 
used for navigation systems, to allow a menu to remain on one part of the window whilst 
looking at different pages of content in the main window.  
 
When you divide your document into frames you must name each frame and decide which 
page to display in which frame. This is called the source. Then, when you are creating links, 
you must specify a target, i.e. which frame the link document will be displayed in. 
 
You are going to create a frameset to look like the following. 
 

 
 
• Select the Frames option 
 

 
 
• Split your document into two 
 
• Choose Windows -> Others -> Frames or press Shift + F2 
 
• Name the left frame menu and the large frame main 
 
• Set the source document for menu to be menu.htm 
 

 
 
• Set the source document for main to be page1.htm 
 
• Preview and save your frameset as frame.htm  
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META Tags  
 
When you search on the Internet you usually enter a few keywords and you then are given a 
list of possible sites, each with a description. How do search engines retrieve this 
information? The answer is Meta tags, extra information included but not displayed on a web 
page that search engines look through and match each time someone carries out a search. 
 

• Go to the Insert menu and choose Head Tags then Keywords or Description 
 
• For Keywords, enter a list of words relevant to the content of your site 

 
• For Description, enter a sentence or two that describes the content of the site 

 
• Using the main search engines you can submit your site for inclusion in their 

directory 
 
 
Forms 
 
Forms are the parts of a webpage that allow you to enter and then submit information. In 
this module you will not learn how to retrieve information from forms as this requires extra 
programming. You can however practice inserting the various form elements on a page and, 
perhaps, find a website that allows you to process form information.  
 
The main elements include text fields, check boxes, radio buttons, list/menus and buttons 
that actually send the information. 
 
 
Rollovers and Flash Text 
 
As a Macromedia product, Dreamweaver integrates closely with other Macromedia programs 
including Flash and Fireworks. 
 
Instead of plain text you can have images for your links.  
 

• Choose Insert -> Interactive Images -> Flash Text to get a list of ready designed, 
animated images that you can use as buttons on your page.  

 
• Enter text to appear on the button 

 
• Select the page to link to and the target of necessary 

 
You can also insert rollover images, Flash text, Fireworks HTML and Flash documents. 
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Homework Exercise 1 
 
 
It may be necessary to search the Internet to find some answers to these questions. 
 
 
1.  A web browser allows you to view web pages. 
 

(a)  Name three web browsers.       (3) 
 

(b)  Who is credited with creating the first web browser?    (1) 
 

(c)  Name a different type of program you may use when connected to  
the Internet.         (1) 

 
 
2.  Napster, Kazaa and Morpheus are examples of peer to peer, file sharing programs.  

They allow people from all over the world to share files stored on their own 
computers.     

 
(a)  Why was Napster closed down by the legal efforts of record companies?  (1) 

 
(b)  How have these programs contributed to the spread of computer  

viruses?         (1) 
 

(c)  If these programs can be downloaded for free, how do these  
companies make any money?       (1) 

 
(d)  The use of these programs is increasing. CD sales are down. How  

might record companies increase their profits?     (1) 
 
 
3.  In ICT, course notes and homework exercises can be found on the Internet.  

Pupils can also talk in a chat room. 
 

(a)  Give one advantage and one disadvantage of accessing notes on the  
Internet.         (2) 

 
(b)  Why are Internet chat rooms so popular?     (1) 

 
 
 

TOTAL (12) 
 
 
 

A+ 12, 11 A- 10, 9 B+ 8 B-  C+ 7 C- 6 N 5 
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Homework Exercise 2 
 
 
1.  Why have WYSIWYG web page creation programs become so popular?  (1) 
 
2.  What are the advantages in being able to edit web pages in three  

different ways?         (1) 
 
3. Describe five different ways of formatting text.     (5) 
 
4. Describe three ways of inserting an image into a document.    (3) 
 
5. What should you name the main page or first page of every site?   (1) 
 
6. (a)  What is a common way of organising folders to contain files in  

a website?        (1) 
 

(b)  Why is it an advantage to arrange files and folders in this way?  (1) 
 

(c)  Describe how the Clavius website is organised.    (1) 
 

(d)  Draw a diagram to represent this folder structure, i.e. a tree diagram to  
show which subfolders are in each folder.    (1) 

 
 
 
          TOTAL (15) 
 
 
 

A+ 15, 14, 13 A- 12, 11 B+ 10 B- 9 C+  C- 8 N 7 
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Homework Exercise 3 
 
 
1.  Describe two different ways of displaying lists of items in a web page.  (2) 
 
2. When you create a new table, describe four properties that you can change  

for that table.         (4) 
 
3. By referring to specific fonts, explain why must you be careful which fonts you  

use when creating a web page?       (2) 
 
4. Describe two ways of altering font size of text in a web page?   (2) 
 
 
          TOTAL (10) 
  
 
 

A+ 10,9 A- 8,7 B+  B- 6 C+  C- 5 N  
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Homework Exercise 4 
 
 
1. What does JPEG stand for?       (1) 
 
2. What are JPEGs used for?       (1) 
 
3. Which program(s) would you use to create JPEGs?    (1) 
 
4. In S1 you learned how to use Flash. How can you use this program when 
 creating web pages in Dreamweaver?      (1) 
 
5. What are animated GIFs?       (1) 
 
6. Why are Flash animations and animated GIFs frequently used on web pages? (1) 
 
7. Apart from text and graphics, what other types of media could you add  

to a website?         (1) 
 
8. Describe three other ways of attracting visitors to visit your website frequently. (3) 
 
 
          TOTAL (10) 
 
 
 
 

A+ 10,9 A- 8,7 B+  B- 6 C+  C- 5 N  
 
 
 


